Requirements

Online CME hardware/software requirements

All CME offerings require the use of a personal computer with a current operating system (i.e. Windows XP, Mac OSX, or an up-to-date Linux distribution) with a live internet connection. In addition, a modern web browser is required such as Internet Explorer 6, Firefox 1.0.7, or Safari. High bandwidth is not required, but preferred for an optimal online experience.

Additional software requrements may include:

  • Macromedia Flash or Shockwave
  • Apple QuickTime
  • Microsoft PowerPoint Player
  • Adobe Acrobat
  • Windows Media Player