Register for Epic Upgrade training

In April, Legacy will move to a new version of Epic, our electronic health record.

To prepare, Legacy is requiring Epic Upgrade training for all active physicians and providers.

Registration is required. Please call or email: 503-413-3363 or Epicprovidertraining@lhs.org

The new version of Epic is sufficiently different that many workflows, especially those that are more complex, will be impacted. We want to ensure that you have an opportunity to learn the new workflows and to also learn about tools and resources in Epic that will help you be more efficient in using the EHR.

Physicians and provider classes are four hours in length and are running now through April 10. Please contact us at the Epic registration number above as soon as possible for the best choice of time and location. Review the course catalog, which includes scheduled class times.